Mission and Overview
NVD is the U.S. government repository of standards based vulnerability management data. This data enables automation of vulnerability management, security measurement, and compliance (e.g. FISMA).
Resource Status
NVD contains:

Last updated: 7/25/2014 1:39:29 PM

CVE Publication rate: 19.37

Email List

NVD provides four mailing lists to the public. For information and subscription instructions please visit NVD Mailing Lists

Workload Index
Vulnerability Workload Index: 7.14
About Us
NVD is a product of the NIST Computer Security Division and is sponsored by the Department of Homeland Security's National Cyber Security Division. It supports the U.S. government multi-agency (OSD, DHS, NSA, DISA, and NIST) Information Security Automation Program. It is the U.S. government content repository for the Security Content Automation Protocol (SCAP).

National Cyber Awareness System

Vulnerability Summary for CVE-2013-6458

Original release date: 01/24/2014
Last revised: 03/05/2014
Source: US-CERT/NIST

Overview

Multiple race conditions in the (1) virDomainBlockStats, (2) virDomainGetBlockInf, (3) qemuDomainBlockJobImpl, and (4) virDomainGetBlockIoTune functions in libvirt before 1.2.1 do not properly verify that the disk is attached, which allows remote read-only attackers to cause a denial of service (libvirtd crash) via the virDomainDetachDeviceFlags command.

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score: 6.8 (MEDIUM) (AV:A/AC:H/Au:N/C:C/I:C/A:C) (legend)
Impact Subscore: 10.0
Exploitability Subscore: 3.2
CVSS Version 2 Metrics:
Access Vector: Local network exploitable
Access Complexity: High
Authentication: Not required to exploit
Impact Type: Allows unauthorized disclosure of information; Allows unauthorized modification; Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

External Source: SECUNIA
Name: 56186
Type: Advisory
External Source: REDHAT
Name: RHSA-2014:0103
External Source: SECUNIA
Name: 56446
Type: Advisory
External Source: DEBIAN
Name: DSA-2846
External Source: UBUNTU
Name: USN-2093-1
External Source: CONFIRM
Name: http://libvirt.org/news.html
External Source: SUSE
Name: openSUSE-SU-2014:0270
External Source: SUSE
Name: openSUSE-SU-2014:0268
External Source: CONFIRM
Name: https://bugzilla.redhat.com/show_bug.cgi?id=1043069
Type: Advisory

Vulnerable software and versions

Skip Navigation Links.
Collapse Configuration 1Configuration 1
Collapse OROR
* cpe:/a:redhat:libvirt:0.0.1
* cpe:/a:redhat:libvirt:0.0.2
* cpe:/a:redhat:libvirt:0.0.3
* cpe:/a:redhat:libvirt:0.0.4
* cpe:/a:redhat:libvirt:0.0.5
* cpe:/a:redhat:libvirt:0.0.6
* cpe:/a:redhat:libvirt:0.1.0
* cpe:/a:redhat:libvirt:0.1.1
* cpe:/a:redhat:libvirt:0.1.3
* cpe:/a:redhat:libvirt:0.1.4
* cpe:/a:redhat:libvirt:0.1.5
* cpe:/a:redhat:libvirt:0.1.6
* cpe:/a:redhat:libvirt:0.1.7
* cpe:/a:redhat:libvirt:0.1.8
* cpe:/a:redhat:libvirt:0.1.9
* cpe:/a:redhat:libvirt:0.10.0
* cpe:/a:redhat:libvirt:0.10.1
* cpe:/a:redhat:libvirt:0.10.2
* cpe:/a:redhat:libvirt:0.10.2.1
* cpe:/a:redhat:libvirt:0.10.2.2
* cpe:/a:redhat:libvirt:0.10.2.3
* cpe:/a:redhat:libvirt:0.10.2.4
* cpe:/a:redhat:libvirt:0.10.2.5
* cpe:/a:redhat:libvirt:0.10.2.6
* cpe:/a:redhat:libvirt:0.10.2.7
* cpe:/a:redhat:libvirt:0.10.2.8
* cpe:/a:redhat:libvirt:0.2.0
* cpe:/a:redhat:libvirt:0.2.1
* cpe:/a:redhat:libvirt:0.2.2
* cpe:/a:redhat:libvirt:0.2.3
* cpe:/a:redhat:libvirt:0.3.0
* cpe:/a:redhat:libvirt:0.3.1
* cpe:/a:redhat:libvirt:0.3.2
* cpe:/a:redhat:libvirt:0.3.3
* cpe:/a:redhat:libvirt:0.4.0
* cpe:/a:redhat:libvirt:0.4.1
* cpe:/a:redhat:libvirt:0.4.2
* cpe:/a:redhat:libvirt:0.4.3
* cpe:/a:redhat:libvirt:0.4.4
* cpe:/a:redhat:libvirt:0.4.5
* cpe:/a:redhat:libvirt:0.4.6
* cpe:/a:redhat:libvirt:0.5.0
* cpe:/a:redhat:libvirt:0.5.1
* cpe:/a:redhat:libvirt:0.6.0
* cpe:/a:redhat:libvirt:0.6.1
* cpe:/a:redhat:libvirt:0.6.2
* cpe:/a:redhat:libvirt:0.6.3
* cpe:/a:redhat:libvirt:0.6.4
* cpe:/a:redhat:libvirt:0.6.5
* cpe:/a:redhat:libvirt:0.7.0
* cpe:/a:redhat:libvirt:0.7.1
* cpe:/a:redhat:libvirt:0.7.2
* cpe:/a:redhat:libvirt:0.7.3
* cpe:/a:redhat:libvirt:0.7.4
* cpe:/a:redhat:libvirt:0.7.5
* cpe:/a:redhat:libvirt:0.7.6
* cpe:/a:redhat:libvirt:0.7.7
* cpe:/a:redhat:libvirt:0.8.0
* cpe:/a:redhat:libvirt:0.8.1
* cpe:/a:redhat:libvirt:0.8.2
* cpe:/a:redhat:libvirt:0.8.3
* cpe:/a:redhat:libvirt:0.8.4
* cpe:/a:redhat:libvirt:0.8.5
* cpe:/a:redhat:libvirt:0.8.6
* cpe:/a:redhat:libvirt:0.8.7
* cpe:/a:redhat:libvirt:0.8.8
* cpe:/a:redhat:libvirt:0.9.0
* cpe:/a:redhat:libvirt:0.9.1
* cpe:/a:redhat:libvirt:0.9.10
* cpe:/a:redhat:libvirt:0.9.11
* cpe:/a:redhat:libvirt:0.9.11.1
* cpe:/a:redhat:libvirt:0.9.11.2
* cpe:/a:redhat:libvirt:0.9.11.3
* cpe:/a:redhat:libvirt:0.9.11.4
* cpe:/a:redhat:libvirt:0.9.11.5
* cpe:/a:redhat:libvirt:0.9.11.6
* cpe:/a:redhat:libvirt:0.9.11.7
* cpe:/a:redhat:libvirt:0.9.11.8
* cpe:/a:redhat:libvirt:0.9.12
* cpe:/a:redhat:libvirt:0.9.13
* cpe:/a:redhat:libvirt:0.9.2
* cpe:/a:redhat:libvirt:0.9.3
* cpe:/a:redhat:libvirt:0.9.4
* cpe:/a:redhat:libvirt:0.9.5
* cpe:/a:redhat:libvirt:0.9.6
* cpe:/a:redhat:libvirt:0.9.6.1
* cpe:/a:redhat:libvirt:0.9.6.2
* cpe:/a:redhat:libvirt:0.9.6.3
* cpe:/a:redhat:libvirt:0.9.7
* cpe:/a:redhat:libvirt:0.9.8
* cpe:/a:redhat:libvirt:0.9.9
* cpe:/a:redhat:libvirt:1.0.0
* cpe:/a:redhat:libvirt:1.0.1
* cpe:/a:redhat:libvirt:1.0.2
* cpe:/a:redhat:libvirt:1.0.3
* cpe:/a:redhat:libvirt:1.0.4
* cpe:/a:redhat:libvirt:1.0.5
* cpe:/a:redhat:libvirt:1.0.5.1
* cpe:/a:redhat:libvirt:1.0.5.2
* cpe:/a:redhat:libvirt:1.0.5.3
* cpe:/a:redhat:libvirt:1.0.5.4
* cpe:/a:redhat:libvirt:1.0.5.5
* cpe:/a:redhat:libvirt:1.0.5.6
* cpe:/a:redhat:libvirt:1.0.6
* cpe:/a:redhat:libvirt:1.1.0
* cpe:/a:redhat:libvirt:1.1.1
* cpe:/a:redhat:libvirt:1.1.2
* cpe:/a:redhat:libvirt:1.1.3
* cpe:/a:redhat:libvirt:1.1.4
* cpe:/a:redhat:libvirt:1.2.0 and previous versions
* Denotes Vulnerable Software
Changes related to vulnerability configurations

Technical Details

Vulnerability Type (View All)