Mission and Overview
NVD is the U.S. government repository of standards based vulnerability management data. This data enables automation of vulnerability management, security measurement, and compliance (e.g. FISMA).
Resource Status
NVD contains:

Last updated: 10/31/2014 8:34:32 PM

CVE Publication rate: 47

Email List

NVD provides four mailing lists to the public. For information and subscription instructions please visit NVD Mailing Lists

Workload Index
Vulnerability Workload Index: 13.95
About Us
NVD is a product of the NIST Computer Security Division and is sponsored by the Department of Homeland Security's National Cyber Security Division. It supports the U.S. government multi-agency (OSD, DHS, NSA, DISA, and NIST) Information Security Automation Program. It is the U.S. government content repository for the Security Content Automation Protocol (SCAP).

National Cyber Awareness System

Vulnerability Summary for CVE-2013-4248

Original release date: 08/17/2013
Last revised: 07/17/2014
Source: US-CERT/NIST

Overview

The openssl_x509_parse function in openssl.c in the OpenSSL module in PHP before 5.4.18 and 5.5.x before 5.5.2 does not properly handle a '\0' character in a domain name in the Subject Alternative Name field of an X.509 certificate, which allows man-in-the-middle attackers to spoof arbitrary SSL servers via a crafted certificate issued by a legitimate Certification Authority, a related issue to CVE-2009-2408.

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score: 4.3 (MEDIUM) (AV:N/AC:M/Au:N/C:N/I:P/A:N) (legend)
Impact Subscore: 2.9
Exploitability Subscore: 8.6
CVSS Version 2 Metrics:
Access Vector: Network exploitable
Access Complexity: Medium
Authentication: Not required to exploit
Impact Type: Allows unauthorized modification

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

External Source: CONFIRM
Name: http://git.php.net/?p=php-src.git;a=commit;h=2874696a5a8d46639d261571f915c493cd875897
External Source: SECUNIA
Name: 54657
Type: Advisory
External Source: SECUNIA
Name: 54478
Type: Advisory
External Source: REDHAT
Name: RHSA-2013:1615
External Source: SUSE
Name: openSUSE-SU-2013:1963
External Source: SECUNIA
Name: 55078
Type: Advisory
External Source: SECUNIA
Name: 59652
External Source: REDHAT
Name: RHSA-2013:1307
Type: Advisory
External Source: DEBIAN
Name: DSA-2742
External Source: CONFIRM
Name: http://www.php.net/ChangeLog-5.php
External Source: UBUNTU
Name: USN-1937-1
Type: Advisory
External Source: SECTRACK
Name: 1028924
External Source: CONFIRM
Name: http://support.apple.com/kb/HT6150
External Source: SUSE
Name: openSUSE-SU-2013:1964

Vulnerable software and versions

Skip Navigation Links.
Collapse Configuration 1Configuration 1
Collapse OROR
* cpe:/a:php:php:5.4.17 and previous versions
* cpe:/a:php:php:5.5.0
* cpe:/a:php:php:5.5.1
* cpe:/a:php:php:5.4.9
* cpe:/a:php:php:5.4.8
* cpe:/a:php:php:5.4.7
* cpe:/a:php:php:5.4.6
* cpe:/a:php:php:5.4.5
* cpe:/a:php:php:5.4.4
* cpe:/a:php:php:5.4.3
* cpe:/a:php:php:5.4.2
* cpe:/a:php:php:5.4.16:rc1
* cpe:/a:php:php:5.4.15:rc1
* cpe:/a:php:php:5.4.14:rc1
* cpe:/a:php:php:5.4.14
* cpe:/a:php:php:5.4.13:rc1
* cpe:/a:php:php:5.4.13
* cpe:/a:php:php:5.4.12:rc2
* cpe:/a:php:php:5.4.12:rc1
* cpe:/a:php:php:5.4.12
* cpe:/a:php:php:5.4.11
* cpe:/a:php:php:5.4.10
* cpe:/a:php:php:5.4.1
* cpe:/a:php:php:5.4.0
* cpe:/a:php:php:5.3.9
* cpe:/a:php:php:5.3.8
* cpe:/a:php:php:5.3.7
* cpe:/a:php:php:5.3.6
* cpe:/a:php:php:5.3.5
* cpe:/a:php:php:5.3.4
* cpe:/a:php:php:5.3.3
* cpe:/a:php:php:5.3.27
* cpe:/a:php:php:5.3.26
* cpe:/a:php:php:5.3.25
* cpe:/a:php:php:5.3.24
* cpe:/a:php:php:5.3.23
* cpe:/a:php:php:5.3.22
* cpe:/a:php:php:5.3.21
* cpe:/a:php:php:5.3.20
* cpe:/a:php:php:5.3.2
* cpe:/a:php:php:5.3.19
* cpe:/a:php:php:5.3.18
* cpe:/a:php:php:5.3.17
* cpe:/a:php:php:5.3.16
* cpe:/a:php:php:5.3.15
* cpe:/a:php:php:5.3.14
* cpe:/a:php:php:5.3.13
* cpe:/a:php:php:5.3.12
* cpe:/a:php:php:5.3.11
* cpe:/a:php:php:5.3.10
* cpe:/a:php:php:5.3.1
* cpe:/a:php:php:5.3.0
* cpe:/a:php:php:5.2.9
* cpe:/a:php:php:5.2.8
* cpe:/a:php:php:5.2.7
* cpe:/a:php:php:5.2.6
* cpe:/a:php:php:5.2.5
* cpe:/a:php:php:5.2.4
* cpe:/a:php:php:5.2.3
* cpe:/a:php:php:5.2.2
* cpe:/a:php:php:5.2.17
* cpe:/a:php:php:5.2.16
* cpe:/a:php:php:5.2.15
* cpe:/a:php:php:5.2.14
* cpe:/a:php:php:5.2.13
* cpe:/a:php:php:5.2.12
* cpe:/a:php:php:5.2.11
* cpe:/a:php:php:5.2.10
* cpe:/a:php:php:5.2.1
* cpe:/a:php:php:5.2.0
* cpe:/a:php:php:5.1.6
* cpe:/a:php:php:5.1.5
* cpe:/a:php:php:5.1.4
* cpe:/a:php:php:5.1.3
* cpe:/a:php:php:5.1.2
* cpe:/a:php:php:5.1.1
* cpe:/a:php:php:5.1.0
* cpe:/a:php:php:5.0.5
* cpe:/a:php:php:5.0.4
* cpe:/a:php:php:5.0.3
* cpe:/a:php:php:5.0.2
* cpe:/a:php:php:5.0.1
* cpe:/a:php:php:5.0.0:rc3
* cpe:/a:php:php:5.0.0:rc2
* cpe:/a:php:php:5.0.0:rc1
* cpe:/a:php:php:5.0.0:beta4
* cpe:/a:php:php:5.0.0:beta3
* cpe:/a:php:php:5.0.0:beta2
* cpe:/a:php:php:5.0.0:beta1
* cpe:/a:php:php:5.0.0
Collapse Configuration 2Configuration 2
Collapse OROR
* cpe:/o:redhat:enterprise_linux:5
Collapse Configuration 3Configuration 3
Collapse OROR
* cpe:/o:canonical:ubuntu_linux:12.10
* cpe:/o:canonical:ubuntu_linux:13.04
* cpe:/o:canonical:ubuntu_linux:10.04:-:lts
* cpe:/o:canonical:ubuntu_linux:12.04:-:lts
* Denotes Vulnerable Software
Changes related to vulnerability configurations

Technical Details

Vulnerability Type (View All)