Mission and Overview
NVD is the U.S. government repository of standards based vulnerability management data. This data enables automation of vulnerability management, security measurement, and compliance (e.g. FISMA).
Resource Status
NVD contains:

Last updated: 7/23/2014 2:03:57 PM

CVE Publication rate: 18.87

Email List

NVD provides four mailing lists to the public. For information and subscription instructions please visit NVD Mailing Lists

Workload Index
Vulnerability Workload Index: 6.79
About Us
NVD is a product of the NIST Computer Security Division and is sponsored by the Department of Homeland Security's National Cyber Security Division. It supports the U.S. government multi-agency (OSD, DHS, NSA, DISA, and NIST) Information Security Automation Program. It is the U.S. government content repository for the Security Content Automation Protocol (SCAP).

National Cyber Awareness System

Vulnerability Summary for CVE-2012-6645

Original release date: 04/08/2014
Last revised: 04/08/2014
Source: US-CERT/NIST

Overview

Cross-site scripting (XSS) vulnerability in the autocomplete functionality in the Finder module 6.x-1.x before 6.x-1.26, 7.x-1.x, and 7.x-2.x before 7.x-2.0-alpha8 for Drupal allows remote attackers to inject arbitrary web script or HTML via the title of a node, a different vulnerability than CVE-2012-1561.

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score: 4.3 (MEDIUM) (AV:N/AC:M/Au:N/C:N/I:P/A:N) (legend)
Impact Subscore: 2.9
Exploitability Subscore: 8.6
CVSS Version 2 Metrics:
Access Vector: Network exploitable; Victim must voluntarily interact with attack mechanism
Access Complexity: Medium
Authentication: Not required to exploit
Impact Type: Allows unauthorized modification

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

External Source: SECUNIA
Name: 47941
External Source: CONFIRM
Name: http://drupal.org/node/1432318
External Source: MLIST
Name: [oss-security] 20120316 CVE-request: Drupal Finder SA-CONTRIB-2012-017
External Source: CONFIRM
Name: http://drupalcode.org/project/finder.git/commit/13e2d0c
External Source: CONFIRM
Name: http://drupalcode.org/project/finder.git/commit/58443aa
External Source: CONFIRM
Name: http://drupalcode.org/project/finder.git/commit/bc0cc82
External Source: XF
Name: drupal-finder-unspecified-xss(73110)
External Source: SECUNIA
Name: 47943
Type: Advisory
External Source: CONFIRM
Name: http://drupal.org/node/1432320
Type: Advisory; Patch Information
External Source: CONFIRM
Name: http://drupalcode.org/project/finder.git/commit/758fcf9
External Source: MLIST
Name: [oss-security] 20120319 Re: CVE-request: Drupal Finder SA-CONTRIB-2012-017
External Source: OSVDB
Name: 79015
External Source: MLIST
Name: [oss-security] 20120406 CVE's for Drupal Contrib 2012 001 through 057 (67 new CVE assignments)
External Source: MISC
Name: https://drupal.org/node/1432970
External Source: MISC
Name: http://www.madirish.net/content/drupal-finder-6x-19-xss-and-remote-code-execution-vulnerabilities

Vulnerable software and versions

Skip Navigation Links.
Collapse Configuration 1Configuration 1
Collapse OROR
* cpe:/a:danielb:finder:7.x-2.0:alpha1
* cpe:/a:danielb:finder:7.x-2.0:alpha2
* cpe:/a:danielb:finder:7.x-2.0:alpha3
* cpe:/a:danielb:finder:7.x-2.0:alpha4
* cpe:/a:danielb:finder:7.x-2.0:alpha5
* cpe:/a:danielb:finder:7.x-2.0:alpha6
* cpe:/a:danielb:finder:7.x-2.x:dev
* cpe:/a:danielb:finder:7.x-1.0
* cpe:/a:danielb:finder:7.x-1.1
* cpe:/a:danielb:finder:7.x-1.2
* cpe:/a:danielb:finder:7.x-1.3
* cpe:/a:danielb:finder:7.x-1.4
* cpe:/a:danielb:finder:7.x-1.5
* cpe:/a:danielb:finder:7.x-1.6
* cpe:/a:danielb:finder:7.x-1.x:dev
* cpe:/a:danielb:finder:6.x-1.25
* cpe:/a:danielb:finder:6.x-1.0
* cpe:/a:danielb:finder:6.x-1.0:alpha1
* cpe:/a:danielb:finder:6.x-1.0:alpha10
* cpe:/a:danielb:finder:6.x-1.0:alpha11
* cpe:/a:danielb:finder:6.x-1.0:alpha12
* cpe:/a:danielb:finder:6.x-1.0:alpha13
* cpe:/a:danielb:finder:6.x-1.0:alpha14
* cpe:/a:danielb:finder:6.x-1.0:alpha15
* cpe:/a:danielb:finder:6.x-1.0:alpha16
* cpe:/a:danielb:finder:6.x-1.0:alpha17
* cpe:/a:danielb:finder:6.x-1.0:alpha18
* cpe:/a:danielb:finder:6.x-1.0:alpha19
* cpe:/a:danielb:finder:6.x-1.0:alpha2
* cpe:/a:danielb:finder:6.x-1.0:alpha20
* cpe:/a:danielb:finder:6.x-1.0:alpha21
* cpe:/a:danielb:finder:6.x-1.0:alpha22
* cpe:/a:danielb:finder:6.x-1.0:alpha23
* cpe:/a:danielb:finder:6.x-1.0:alpha24
* cpe:/a:danielb:finder:6.x-1.0:alpha25
* cpe:/a:danielb:finder:6.x-1.0:alpha26
* cpe:/a:danielb:finder:6.x-1.0:alpha27
* cpe:/a:danielb:finder:6.x-1.0:alpha28
* cpe:/a:danielb:finder:6.x-1.0:alpha3
* cpe:/a:danielb:finder:6.x-1.0:alpha4
* cpe:/a:danielb:finder:6.x-1.0:alpha5
* cpe:/a:danielb:finder:6.x-1.0:alpha6
* cpe:/a:danielb:finder:6.x-1.0:alpha7
* cpe:/a:danielb:finder:6.x-1.0:alpha8
* cpe:/a:danielb:finder:6.x-1.0:alpha9
* cpe:/a:danielb:finder:6.x-1.0:beta1
* cpe:/a:danielb:finder:6.x-1.0:beta2
* cpe:/a:danielb:finder:6.x-1.0:beta3
* cpe:/a:danielb:finder:6.x-1.0:rc1
* cpe:/a:danielb:finder:6.x-1.0:rc2
* cpe:/a:danielb:finder:6.x-1.0:rc3
* cpe:/a:danielb:finder:6.x-1.0:rc4
* cpe:/a:danielb:finder:6.x-1.0:unstable0
* cpe:/a:danielb:finder:6.x-1.0:unstable1
* cpe:/a:danielb:finder:6.x-1.0:unstable2
* cpe:/a:danielb:finder:6.x-1.0:unstable3
* cpe:/a:danielb:finder:6.x-1.0:unstable4
* cpe:/a:danielb:finder:6.x-1.0:unstable5
* cpe:/a:danielb:finder:6.x-1.0:unstable6
* cpe:/a:danielb:finder:6.x-1.0:unstable7
* cpe:/a:danielb:finder:6.x-1.1
* cpe:/a:danielb:finder:6.x-1.10
* cpe:/a:danielb:finder:6.x-1.11
* cpe:/a:danielb:finder:6.x-1.12
* cpe:/a:danielb:finder:6.x-1.13
* cpe:/a:danielb:finder:6.x-1.14
* cpe:/a:danielb:finder:6.x-1.15
* cpe:/a:danielb:finder:6.x-1.16
* cpe:/a:danielb:finder:6.x-1.17
* cpe:/a:danielb:finder:6.x-1.18
* cpe:/a:danielb:finder:6.x-1.19
* cpe:/a:danielb:finder:6.x-1.24
* cpe:/a:danielb:finder:6.x-1.23
* cpe:/a:danielb:finder:6.x-1.21
* cpe:/a:danielb:finder:6.x-1.20
* cpe:/a:danielb:finder:6.x-1.2
* cpe:/a:danielb:finder:6.x-1.3
* cpe:/a:danielb:finder:6.x-1.4
* cpe:/a:danielb:finder:6.x-1.5
* cpe:/a:danielb:finder:6.x-1.9
* cpe:/a:danielb:finder:6.x-1.8
* cpe:/a:danielb:finder:6.x-1.7
* cpe:/a:danielb:finder:6.x-1.6
* cpe:/a:danielb:finder:6.x-1.x-dev
* Denotes Vulnerable Software
Changes related to vulnerability configurations

Technical Details

Vulnerability Type (View All)
  • Cross-Site Scripting (XSS) (CWE-79)