Mission and Overview
NVD is the U.S. government repository of standards based vulnerability management data. This data enables automation of vulnerability management, security measurement, and compliance (e.g. FISMA).
Resource Status
NVD contains:

Last updated: 4/23/2014

CVE Publication rate: 20.9

Email List

NVD provides four mailing lists to the public. For information and subscription instructions please visit NVD Mailing Lists

Workload Index
Vulnerability Workload Index: 8.76
About Us
NVD is a product of the NIST Computer Security Division and is sponsored by the Department of Homeland Security's National Cyber Security Division. It supports the U.S. government multi-agency (OSD, DHS, NSA, DISA, and NIST) Information Security Automation Program. It is the U.S. government content repository for the Security Content Automation Protocol (SCAP).

National Cyber Awareness System

Vulnerability Summary for CVE-2010-4159

Original release date: 11/17/2010
Last revised: 12/09/2010
Source: US-CERT/NIST

Overview

Untrusted search path vulnerability in metadata/loader.c in Mono 2.8 and earlier allows local users to gain privileges via a Trojan horse shared library in the current working directory.

Description

Per: http://cwe.mitre.org/data/definitions/426.html 'CWE-426: Untrusted Search Path'

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score: 6.9 (HIGH) (AV:L/AC:M/AU:N/C:C/I:C/A:C) (legend)
Impact Subscore: 10.0
Exploitability Subscore: 3.4
CVSS Version 2 Metrics:
Access Vector: Locally exploitable; Victim must voluntarily interact with attack mechanism
Access Complexity: Medium
Authentication: Not required to exploit
Impact Type: Allows unauthorized disclosure of information; Allows unauthorized modification; Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

External Source: MLIST
Name: [oss-security] 20101110 CVE request: mono loading shared libs from cwd
External Source: VUPEN
Name: ADV-2010-3059
External Source: BID
Name: 44810
External Source: MANDRIVA
Name: MDVSA-2010:240
External Source: CONFIRM
Name: https://bugzilla.novell.com/show_bug.cgi?id=641915
External Source: MLIST
Name: [mono-patches] 20101012 [mono/mono] d3985be4: Search for dllimported shared libs in the base directory, not cwd.
Type: Patch Information
External Source: SECUNIA
Name: 42174
Type: Advisory
External Source: CONFIRM
Name: http://www.mono-project.com/Vulnerabilities#Mono_Runtime_Insecure_Native_Library_Loading
External Source: MLIST
Name: [oss-security] 20101110 Re: CVE request: mono loading shared libs from cwd
External Source: MLIST
Name: [oss-security] 20101110 Re: CVE request: mono loading shared libs from cwd
External Source: CONFIRM
Name: https://github.com/mono/mono/commit/8e890a3bf80a4620e417814dc14886b1bbd17625
Type: Patch Information

Vulnerable software and versions

Skip Navigation Links.
Collapse Configuration 1Configuration 1
Collapse OROR
* cpe:/a:mono:mono:1.0.1
* cpe:/a:mono:mono:1.1.8.1
* cpe:/a:mono:mono:1.1.17
* cpe:/a:mono:mono:1.1.9
* cpe:/a:mono:mono:1.1.18
* cpe:/a:mono:mono:1.1.7
* cpe:/a:mono:mono:1.1.4
* cpe:/a:mono:mono:1.1.8
* cpe:/a:mono:mono:1.1.13
* cpe:/a:mono:mono:1.1.8.3
* cpe:/a:mono:mono:1.1.10
* cpe:/a:mono:mono:1.1.10.1
* cpe:/a:mono:mono:1.0
* cpe:/a:mono:mono:1.1.9.1
* cpe:/a:mono:mono:1.1.13.7
* cpe:/a:mono:mono:1.1.9.2
* cpe:/a:mono:mono:1.1.17.1
* cpe:/a:mono:mono:1.1.13.4
* cpe:/a:mono:mono:1.0.6
* cpe:/a:mono:mono:1.1.13.6
* cpe:/a:mono:mono:1.1.1
* cpe:/a:mono:mono:1.0.2
* cpe:/a:mono:mono:1.0.4
* cpe:/a:mono:mono:1.1.5
* cpe:/a:mono:mono:1.1.6
* cpe:/a:mono:mono:1.1.2
* cpe:/a:mono:mono:1.1.3
* cpe:/a:mono:mono:1.0.5
* cpe:/a:mono:mono:1.2.5.1
* cpe:/a:mono:mono:2.0.1
* cpe:/a:mono:mono:1.9.1
* cpe:/a:mono:mono:1.9
* cpe:/a:mono:mono:1.2.6
* cpe:/a:mono:mono:1.2.5.2
* cpe:/a:mono:mono:1.2.5
* cpe:/a:mono:mono:1.2.4
* cpe:/a:mono:mono:1.2.3.1
* cpe:/a:mono:mono:1.1.17.2
* cpe:/a:mono:mono:2.4.3
* cpe:/a:mono:mono:2.4.2.3
* cpe:/a:mono:mono:2.4.2.2
* cpe:/a:mono:mono:2.4.2.1
* cpe:/a:mono:mono:2.4.2
* cpe:/a:mono:mono:2.4
* cpe:/a:mono:mono:2.2
* cpe:/a:mono:mono:1.1.13.8.1
* cpe:/a:mono:mono:1.1.14
* cpe:/a:mono:mono:1.1.13.5
* cpe:/a:mono:mono:1.1.13.8
* cpe:/a:mono:mono:2.0
* cpe:/a:mono:mono:1.1.12.1
* cpe:/a:mono:mono:1.1.13.2
* cpe:/a:mono:mono:1.1.11
* cpe:/a:mono:mono:1.1.12
* cpe:/a:mono:mono:1.2.2.1
* cpe:/a:mono:mono:1.2.3
* cpe:/a:mono:mono:1.2.1
* cpe:/a:mono:mono:1.2.2
* cpe:/a:mono:mono:1.1.16.1
* cpe:/a:mono:mono:1.2
* cpe:/a:mono:mono:1.1.15
* cpe:/a:mono:mono:1.1.16
* cpe:/a:mono:mono:2.6.7 and previous versions
* cpe:/a:mono:mono:2.6.4
* cpe:/a:mono:mono:2.6.3
* cpe:/a:mono:mono:2.6
* Denotes Vulnerable Software
Changes related to vulnerability configurations

Technical Details

Vulnerability Type (View All)