Mission and Overview
NVD is the U.S. government repository of standards based vulnerability management data. This data enables automation of vulnerability management, security measurement, and compliance (e.g. FISMA).
Resource Status
NVD contains:

Last updated: 10/2/2014 11:02:31 AM

CVE Publication rate: 40.1

Email List

NVD provides four mailing lists to the public. For information and subscription instructions please visit NVD Mailing Lists

Workload Index
Vulnerability Workload Index: 11.49
About Us
NVD is a product of the NIST Computer Security Division and is sponsored by the Department of Homeland Security's National Cyber Security Division. It supports the U.S. government multi-agency (OSD, DHS, NSA, DISA, and NIST) Information Security Automation Program. It is the U.S. government content repository for the Security Content Automation Protocol (SCAP).

National Cyber Awareness System

Vulnerability Summary for CVE-2009-2993

Original release date: 10/19/2009
Last revised: 08/21/2010
Source: US-CERT/NIST

Overview

The JavaScript for Acrobat API in Adobe Reader and Acrobat 7.x before 7.1.4, 8.x before 8.1.7, and 9.x before 9.2 does not properly implement the (1) Privileged Context and (2) Safe Path restrictions for unspecified JavaScript methods, which allows remote attackers to create arbitrary files, and possibly execute arbitrary code, via the cPath parameter in a crafted PDF file. NOTE: some of these details are obtained from third party information.

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score: 9.3 (HIGH) (AV:N/AC:M/Au:N/C:C/I:C/A:C) (legend)
Impact Subscore: 10.0
Exploitability Subscore: 8.6
CVSS Version 2 Metrics:
Access Vector: Network exploitable; Victim must voluntarily interact with attack mechanism
Access Complexity: Medium
Authentication: Not required to exploit
Impact Type: Allows unauthorized disclosure of information; Allows unauthorized modification; Allows disruption of service
Per: http://www.adobe.com/support/security/bulletins/apsb09-15.html Critical vulnerabilities have been identified in Adobe Reader 9.1.3 and Acrobat 9.1.3, Adobe Reader 8.1.6 and Acrobat 8.1.6 for Windows, Macintosh and UNIX, and Adobe Reader 7.1.3 and Acrobat 7.1.3 for Windows and Macintosh. These vulnerabilities could cause the application to crash and could potentially allow an attacker to take control of the affected system. This update represents the second quarterly security update for Adobe Reader and Acrobat. Adobe recommends users of Adobe Reader 9.1.3 and Acrobat 9.1.3 and earlier versions update to Adobe Reader 9.2 and Acrobat 9.2. Adobe recommends users of Acrobat 8.1.6 and earlier versions update to Acrobat 8.1.7, and users of Acrobat 7.1.3 and earlier versions update to Acrobat 7.1.4. For Adobe Reader users who cannot update to Adobe Reader 9.2, Adobe has provided the Adobe Reader 8.1.7 and Adobe Reader 7.1.4 updates. Updates apply to all platforms: Windows, Macintosh and UNIX. Affected software versions Adobe Reader 9.1.3 and earlier versions for Windows, Macintosh, and UNIX Adobe Acrobat 9.1.3 and earlier versions for Windows and Macintosh

Solution

Per: http://www.adobe.com/support/security/bulletins/apsb09-15.html Solution Adobe Reader Adobe Reader users on Windows can find the appropriate update here: http://www.adobe.com/support/downloads/product.jsp?product=10&platform=Windows. Adobe Reader users on Macintosh can find the appropriate update here: http://www.adobe.com/support/downloads/product.jsp?product=10&platform=Macintosh. Adobe Reader users on UNIX can find the appropriate update here: http://www.adobe.com/support/downloads/product.jsp?product=10&platform=Unix. Acrobat Acrobat Standard and Pro users on Windows can find the appropriate update here: http://www.adobe.com/support/downloads/product.jsp?product=1&platform=Windows. Acrobat Pro Extended users on Windows can find the appropriate update here: http://www.adobe.com/support/downloads/product.jsp?product=158&platform=Windows Acrobat 3D users on Windows can find the appropriate update here: http://www.adobe.com/support/downloads/product.jsp?product=112&platform=Windows. Acrobat Pro users on Macintosh can find the appropriate update here: http://www.adobe.com/support/downloads/product.jsp?product=1&platform=Macintosh.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

US-CERT Vulnerability Note: CERT
Name: TA09-286B
Type: Patch Information
External Source: BID
Name: 36638
US-CERT Vulnerability Note: CERT-VN
Name: VU#257117
Type: Patch Information
External Source: SECTRACK
Name: 1023007
External Source: BID
Name: 36664
External Source: VUPEN
Name: ADV-2009-2898
Type: Advisory; Patch Information
External Source: OVAL
Name: oval:org.mitre.oval:def:5822
External Source: CONFIRM
Name: http://www.adobe.com/support/security/bulletins/apsb09-15.html
Type: Advisory; Patch Information

References to Check Content

Identifier: oval:org.mitre.oval:def:5822
Check System: http://oval.mitre.org/XMLSchema/oval-definitions-5

Vulnerable software and versions

Skip Navigation Links.
Collapse Configuration 1Configuration 1
Collapse OROR
* cpe:/a:adobe:acrobat_reader:7.0
* cpe:/a:adobe:acrobat_reader:7.0.1
* cpe:/a:adobe:acrobat_reader:7.0.2
* cpe:/a:adobe:acrobat_reader:7.0.3
* cpe:/a:adobe:acrobat_reader:7.0.4
* cpe:/a:adobe:acrobat_reader:7.0.5
* cpe:/a:adobe:acrobat_reader:7.0.6
* cpe:/a:adobe:acrobat_reader:7.0.7
* cpe:/a:adobe:acrobat_reader:7.0.8
* cpe:/a:adobe:acrobat_reader:7.0.9
* cpe:/a:adobe:acrobat_reader:7.1.0
* cpe:/a:adobe:acrobat_reader:7.1.1
* cpe:/a:adobe:acrobat_reader:7.1.3
* cpe:/a:adobe:acrobat_reader:8.0
* cpe:/a:adobe:acrobat_reader:8.1
* cpe:/a:adobe:acrobat_reader:8.1.1
* cpe:/a:adobe:acrobat_reader:8.1.2
* cpe:/a:adobe:acrobat_reader:8.1.3
* cpe:/a:adobe:acrobat_reader:8.1.4
* cpe:/a:adobe:acrobat_reader:8.1.5
* cpe:/a:adobe:acrobat_reader:8.1.6
* cpe:/a:adobe:acrobat_reader:9.0
* cpe:/a:adobe:acrobat_reader:9.1
* cpe:/a:adobe:acrobat_reader:9.1.1
* cpe:/a:adobe:acrobat_reader:9.1.2
* cpe:/a:adobe:acrobat_reader:9.1.3 and previous versions
Collapse Configuration 2Configuration 2
Collapse OROR
* cpe:/a:adobe:acrobat:7.0
* cpe:/a:adobe:acrobat:7.0.1
* cpe:/a:adobe:acrobat:7.0.2
* cpe:/a:adobe:acrobat:7.0.3
* cpe:/a:adobe:acrobat:7.0.4
* cpe:/a:adobe:acrobat:7.0.5
* cpe:/a:adobe:acrobat:7.0.6
* cpe:/a:adobe:acrobat:7.0.7
* cpe:/a:adobe:acrobat:7.0.8
* cpe:/a:adobe:acrobat:7.0.9
* cpe:/a:adobe:acrobat:7.1.0
* cpe:/a:adobe:acrobat:7.1.1
* cpe:/a:adobe:acrobat:7.1.3
* cpe:/a:adobe:acrobat:8.1
* cpe:/a:adobe:acrobat:8.1.1
* cpe:/a:adobe:acrobat:8.1.2
* cpe:/a:adobe:acrobat:8.1.3
* cpe:/a:adobe:acrobat:8.1.4
* cpe:/a:adobe:acrobat:8.1.6
* cpe:/a:adobe:acrobat:9.0
* cpe:/a:adobe:acrobat:9.1.1
* cpe:/a:adobe:acrobat:9.1.2
* cpe:/a:adobe:acrobat:8.0.0
* cpe:/a:adobe:acrobat:9.1.3 and previous versions
* Denotes Vulnerable Software
Changes related to vulnerability configurations

Technical Details

Vulnerability Type (View All)