Mission and Overview
NVD is the U.S. government repository of standards based vulnerability management data. This data enables automation of vulnerability management, security measurement, and compliance (e.g. FISMA).
Resource Status
NVD contains:

Last updated: 10/30/2014 3:03:19 PM

CVE Publication rate: 46.33

Email List

NVD provides four mailing lists to the public. For information and subscription instructions please visit NVD Mailing Lists

Workload Index
Vulnerability Workload Index: 13.8
About Us
NVD is a product of the NIST Computer Security Division and is sponsored by the Department of Homeland Security's National Cyber Security Division. It supports the U.S. government multi-agency (OSD, DHS, NSA, DISA, and NIST) Information Security Automation Program. It is the U.S. government content repository for the Security Content Automation Protocol (SCAP).

National Cyber Awareness System

Vulnerability Summary for CVE-2009-2664

Original release date: 08/04/2009
Last revised: 08/21/2010
Source: US-CERT/NIST

Overview

The js_watch_set function in js/src/jsdbgapi.cpp in the JavaScript engine in Mozilla Firefox before 3.0.12 allows remote attackers to cause a denial of service (assertion failure and application exit) or possibly execute arbitrary code via a crafted .js file, related to a "memory safety bug." NOTE: this was originally reported as affecting versions before 3.0.13.

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score: 5.0 (MEDIUM) (AV:N/AC:L/Au:N/C:N/I:N/A:P) (legend)
Impact Subscore: 2.9
Exploitability Subscore: 10.0
CVSS Version 2 Metrics:
Access Vector: Network exploitable
Access Complexity: Low
Authentication: Not required to exploit
Impact Type: Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

External Source: SUNALERT
Name: 266148
External Source: CONFIRM
Name: http://www.mozilla.org/security/announce/2009/mfsa2009-45.html
Type: Advisory; Patch Information
External Source: BID
Name: 35927
External Source: OVAL
Name: oval:org.mitre.oval:def:9806
External Source: SECUNIA
Name: 36126
External Source: FEDORA
Name: FEDORA-2009-8279
External Source: FEDORA
Name: FEDORA-2009-8288
External Source: VUPEN
Name: ADV-2009-2142
Type: Advisory; Patch Information
External Source: CONFIRM
Name: https://bugzilla.mozilla.org/show_bug.cgi?id=501270

References to Check Content

Identifier: oval:org.mitre.oval:def:9806
Check System: http://oval.mitre.org/XMLSchema/oval-definitions-5

Vulnerable software and versions

Skip Navigation Links.
Collapse Configuration 1Configuration 1
Collapse OROR
* cpe:/a:mozilla:firefox:2.0.0.14
* cpe:/a:mozilla:firefox:2.0.0.12
* cpe:/a:mozilla:firefox:3.0.1
* cpe:/a:mozilla:firefox:2.0.0.19
* cpe:/a:mozilla:firefox:0.10
* cpe:/a:mozilla:firefox:0.8
* cpe:/a:mozilla:firefox:0.10.1
* cpe:/a:mozilla:firefox:0.9.1
* cpe:/a:mozilla:firefox:0.9
* cpe:/a:mozilla:firefox:2.0:beta_1
* cpe:/a:mozilla:firefox:0.9.3
* cpe:/a:mozilla:firefox:0.9.2
* cpe:/a:mozilla:firefox:1.0.1
* cpe:/a:mozilla:firefox:2.0.0.20
* cpe:/a:mozilla:firefox:1.0
* cpe:/a:mozilla:firefox:3.0.5
* cpe:/a:mozilla:firefox:1.0.3
* cpe:/a:mozilla:firefox:0.9:rc
* cpe:/a:mozilla:firefox:1.0.2
* cpe:/a:mozilla:firefox:3.0
* cpe:/a:mozilla:firefox:1.0.5
* cpe:/a:mozilla:firefox:1.0.4
* cpe:/a:mozilla:firefox:1.0.7
* cpe:/a:mozilla:firefox:1.0.6
* cpe:/a:mozilla:firefox:2.0.0.9
* cpe:/a:mozilla:firefox:1.5
* cpe:/a:mozilla:firefox:1.0.8
* cpe:/a:mozilla:firefox:2.0_.1
* cpe:/a:mozilla:firefox:2.0_.10
* cpe:/a:mozilla:firefox:2.0_.4
* cpe:/a:mozilla:firefox:2.0_.5
* cpe:/a:mozilla:firefox:2.0_.6
* cpe:/a:mozilla:firefox:2.0_.7
* cpe:/a:mozilla:firefox:2.0_.9
* cpe:/a:mozilla:firefox:2.0_8
* cpe:/a:mozilla:firefox:2.0.0.21
* cpe:/a:mozilla:firefox:3.0.7
* cpe:/a:mozilla:firefox:2.0.0.17
* cpe:/a:mozilla:firefox:2.0.0.10
* cpe:/a:mozilla:firefox:2.0.0.16
* cpe:/a:mozilla:firefox:2.0.0.11
* cpe:/a:mozilla:firefox:1.4.1
* cpe:/a:mozilla:firefox:2.0.0.15
* cpe:/a:mozilla:firefox:0.6.1
* cpe:/a:mozilla:firefox:0.7
* cpe:/a:mozilla:firefox:0.7.1
* cpe:/a:mozilla:firefox:1.0:preview_release
* cpe:/a:mozilla:firefox:0.3
* cpe:/a:mozilla:firefox:0.4
* cpe:/a:mozilla:firefox:0.5
* cpe:/a:mozilla:firefox:0.6
* cpe:/a:mozilla:firefox:0.1
* cpe:/a:mozilla:firefox:0.2
* cpe:/a:mozilla:firefox:1.5.0.4
* cpe:/a:mozilla:firefox:1.5.0.5
* cpe:/a:mozilla:firefox:1.5.0.2
* cpe:/a:mozilla:firefox:1.5.0.3
* cpe:/a:mozilla:firefox:1.5.0.11
* cpe:/a:mozilla:firefox:2.0.0.7
* cpe:/a:mozilla:firefox:1.5.0.12
* cpe:/a:mozilla:firefox:1.5.0.1
* cpe:/a:mozilla:firefox:1.5.0.10
* cpe:/a:mozilla:firefox:1.5.3
* cpe:/a:mozilla:firefox:1.5.4
* cpe:/a:mozilla:firefox:1.5.1
* cpe:/a:mozilla:firefox:1.5.2
* cpe:/a:mozilla:firefox:1.5.0.8
* cpe:/a:mozilla:firefox:1.5.0.9
* cpe:/a:mozilla:firefox:1.5.0.6
* cpe:/a:mozilla:firefox:1.5.0.7
* cpe:/a:mozilla:firefox:1.5:beta2
* cpe:/a:mozilla:firefox:2.0:beta1
* cpe:/a:mozilla:firefox:2.0
* cpe:/a:mozilla:firefox:1.8
* cpe:/a:mozilla:firefox:1.5.8
* cpe:/a:mozilla:firefox:1.5.7
* cpe:/a:mozilla:firefox:1.5.6
* cpe:/a:mozilla:firefox:1.5.5
* cpe:/a:mozilla:firefox:2.0.0.6
* cpe:/a:mozilla:firefox:2.0.0.5
* cpe:/a:mozilla:firefox:2.0.0.4
* cpe:/a:mozilla:firefox:2.0.0.3
* cpe:/a:mozilla:firefox:0.9_rc
* cpe:/a:mozilla:firefox:2.0.0.2
* cpe:/a:mozilla:firefox:3.0.2
* cpe:/a:mozilla:firefox:2.0.0.1
* cpe:/a:mozilla:firefox:2.0:rc3
* cpe:/a:mozilla:firefox:2.0:rc2
* cpe:/a:mozilla:firefox:3.0.3
* cpe:/a:mozilla:firefox:3.0.11
* cpe:/a:mozilla:firefox:3.0.12
* cpe:/a:mozilla:firefox:2.0.0.8
* cpe:/a:mozilla:firefox:2.0.0.13
* cpe:/a:mozilla:firefox:3.0.10
* cpe:/a:mozilla:firefox:3.0.6
* cpe:/a:mozilla:firefox:1.0.6::linux
* cpe:/a:mozilla:firefox:1.5:beta1
* cpe:/a:mozilla:firefox:3.0.4
* cpe:/a:mozilla:firefox:2.0.0.18
* cpe:/a:mozilla:firefox:3.0.8
* cpe:/a:mozilla:firefox:3.0.9
* cpe:/a:mozilla:firefox:3.5.1 and previous versions
* cpe:/a:mozilla:firefox:3.5
* Denotes Vulnerable Software
Changes related to vulnerability configurations

Technical Details

Vulnerability Type (View All)
  • Resource Management Errors (CWE-399)