Mission and Overview
NVD is the U.S. government repository of standards based vulnerability management data. This data enables automation of vulnerability management, security measurement, and compliance (e.g. FISMA).
Resource Status
NVD contains:

Last updated: 9/2/2014 2:57:41 AM

CVE Publication rate: 13.23

Email List

NVD provides four mailing lists to the public. For information and subscription instructions please visit NVD Mailing Lists

Workload Index
Vulnerability Workload Index: 5.82
About Us
NVD is a product of the NIST Computer Security Division and is sponsored by the Department of Homeland Security's National Cyber Security Division. It supports the U.S. government multi-agency (OSD, DHS, NSA, DISA, and NIST) Information Security Automation Program. It is the U.S. government content repository for the Security Content Automation Protocol (SCAP).

National Cyber Awareness System

Vulnerability Summary for CVE-2008-4326

Original release date: 09/30/2008
Last revised: 03/07/2011
Source: US-CERT/NIST

Overview

The PMA_escapeJsString function in libraries/js_escape.lib.php in phpMyAdmin before 2.11.9.2, when Internet Explorer is used, allows remote attackers to bypass cross-site scripting (XSS) protection mechanisms and conduct XSS attacks via a NUL byte inside a "

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score: 4.3 (MEDIUM) (AV:N/AC:M/Au:N/C:N/I:P/A:N) (legend)
Impact Subscore: 2.9
Exploitability Subscore: 8.6
CVSS Version 2 Metrics:
Access Vector: Network exploitable; Victim must voluntarily interact with attack mechanism
Access Complexity: Medium
Authentication: Not required to exploit
Impact Type: Allows unauthorized modification

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

External Source: CONFIRM
Name: http://phpmyadmin.svn.sourceforge.net/viewvc/phpmyadmin/branches/MAINT_2_11_9/phpMyAdmin/libraries/js_escape.lib.php?r1=11514&r2=11603&pathrev=11603
External Source: VUPEN
Name: ADV-2008-2657
External Source: MLIST
Name: [oss-security] 20080923 CVE req: phpmyadmin < 2.11.9.2 xss
External Source: CONFIRM
Name: http://phpmyadmin.svn.sourceforge.net/viewvc/phpmyadmin/branches/QA_2_11/phpMyAdmin/libraries/js_escape.lib.php?view=log&pathrev=11603
External Source: CONFIRM
Name: http://www.phpmyadmin.net/home_page/security.php?issue=PMASA-2008-8
External Source: JVNDB
Name: JVNDB-2008-000061
External Source: CONFIRM
Name: http://www.phpmyadmin.net/home_page/downloads.php?relnotes=1
External Source: SUSE
Name: SUSE-SR:2009:003
External Source: SECUNIA
Name: 31974
External Source: CONFIRM
Name: http://typo3.org/teams/security/security-bulletins/typo3-20080924-1/
External Source: SECUNIA
Name: 33822
External Source: SECUNIA
Name: 31992
External Source: OSVDB
Name: 48511
External Source: JVN
Name: JVN#54824688
External Source: DEBIAN
Name: DSA-1675
External Source: SECUNIA
Name: 32954

Vulnerable software and versions

Skip Navigation Links.
Collapse Configuration 1Configuration 1
Collapse ANDAND
Collapse OROR
* cpe:/a:phpmyadmin:phpmyadmin:2.0.2
* cpe:/a:phpmyadmin:phpmyadmin:2.0.3
* cpe:/a:phpmyadmin:phpmyadmin:2.0.0
* cpe:/a:phpmyadmin:phpmyadmin:2.0.1
* cpe:/a:phpmyadmin:phpmyadmin:2.1
* cpe:/a:phpmyadmin:phpmyadmin:2.1.0
* cpe:/a:phpmyadmin:phpmyadmin:2.0.4
* cpe:/a:phpmyadmin:phpmyadmin:2.0.5
* cpe:/a:phpmyadmin:phpmyadmin:2.0
* cpe:/a:phpmyadmin:phpmyadmin:2.10.2
* cpe:/a:phpmyadmin:phpmyadmin:2.10.0
* cpe:/a:phpmyadmin:phpmyadmin:2.10.1
* cpe:/a:phpmyadmin:phpmyadmin:2.1.2
* cpe:/a:phpmyadmin:phpmyadmin:2.1.1
* cpe:/a:phpmyadmin:phpmyadmin:2.10.0.2
* cpe:/a:phpmyadmin:phpmyadmin:2.10.0.1
* cpe:/a:phpmyadmin:phpmyadmin:2.10.0.0
* cpe:/a:phpmyadmin:phpmyadmin:2.10.01
* cpe:/a:phpmyadmin:phpmyadmin:2.10.1.0
* cpe:/a:phpmyadmin:phpmyadmin:2.11.1.0
* cpe:/a:phpmyadmin:phpmyadmin:2.11.1
* cpe:/a:phpmyadmin:phpmyadmin:2.11.0
* cpe:/a:phpmyadmin:phpmyadmin:2.10.3
* cpe:/a:phpmyadmin:phpmyadmin:2.10.2.0
* cpe:/a:phpmyadmin:phpmyadmin:2.10.3rc1
* cpe:/a:phpmyadmin:phpmyadmin:2.10.3.0
* cpe:/a:phpmyadmin:phpmyadmin:2.11.0beta1
* cpe:/a:phpmyadmin:phpmyadmin:2.11.0.0
* cpe:/a:phpmyadmin:phpmyadmin:2.11.0rc1
* cpe:/a:phpmyadmin:phpmyadmin:2.11.2.2
* cpe:/a:phpmyadmin:phpmyadmin:2.11.2.0
* cpe:/a:phpmyadmin:phpmyadmin:2.11.1.2
* cpe:/a:phpmyadmin:phpmyadmin:2.11.1.1
* cpe:/a:phpmyadmin:phpmyadmin:2.11.2.1
* cpe:/a:phpmyadmin:phpmyadmin:2.11.3.0
* cpe:/a:phpmyadmin:phpmyadmin:2.11.1rc1
* cpe:/a:phpmyadmin:phpmyadmin:2.11.3rc1
* cpe:/a:phpmyadmin:phpmyadmin:2.11.3
* cpe:/a:phpmyadmin:phpmyadmin:2.11.2
* cpe:/a:phpmyadmin:phpmyadmin:2.11.5.2
* cpe:/a:phpmyadmin:phpmyadmin:2.11.6
* cpe:/a:phpmyadmin:phpmyadmin:2.11.6rc1
* cpe:/a:phpmyadmin:phpmyadmin:2.11.4
* cpe:/a:phpmyadmin:phpmyadmin:2.11.5rc1
* cpe:/a:phpmyadmin:phpmyadmin:2.11.4rc1
* cpe:/a:phpmyadmin:phpmyadmin:2.11.5.0
* cpe:/a:phpmyadmin:phpmyadmin:2.11.4.0
* cpe:/a:phpmyadmin:phpmyadmin:2.11.5.1
* cpe:/a:phpmyadmin:phpmyadmin:2.11.5
* cpe:/a:phpmyadmin:phpmyadmin:2.11.7
* cpe:/a:phpmyadmin:phpmyadmin:2.11.7.0
* cpe:/a:phpmyadmin:phpmyadmin:2.11.8
* cpe:/a:phpmyadmin:phpmyadmin:2.11.9.1 and previous versions
* cpe:/a:phpmyadmin:phpmyadmin:2.11.9
* cpe:/a:phpmyadmin:phpmyadmin:2.2
* cpe:/a:phpmyadmin:phpmyadmin:2.2.0
* cpe:/a:phpmyadmin:phpmyadmin:2.2.0_pre1
* cpe:/a:phpmyadmin:phpmyadmin:2.2.0_pre2
* cpe:/a:phpmyadmin:phpmyadmin:2.2.0_rc1
* cpe:/a:phpmyadmin:phpmyadmin:2.2.0_rc2
* cpe:/a:phpmyadmin:phpmyadmin:2.2_rc1
* cpe:/a:phpmyadmin:phpmyadmin:2.2_pre2
* cpe:/a:phpmyadmin:phpmyadmin:2.2.0_rc3
* cpe:/a:phpmyadmin:phpmyadmin:2.2.2
* cpe:/a:phpmyadmin:phpmyadmin:2.2.3
* cpe:/a:phpmyadmin:phpmyadmin:2.2.4
* cpe:/a:phpmyadmin:phpmyadmin:2.2.5
* cpe:/a:phpmyadmin:phpmyadmin:2.2.6
* cpe:/a:phpmyadmin:phpmyadmin:2.2_pre1
* cpe:/a:phpmyadmin:phpmyadmin:2.2.7_pl1
* cpe:/a:phpmyadmin:phpmyadmin:2.3.1
* cpe:/a:phpmyadmin:phpmyadmin:2.3.2
* cpe:/a:phpmyadmin:phpmyadmin:2.2_rc3
* cpe:/a:phpmyadmin:phpmyadmin:2.4.0
* cpe:/a:phpmyadmin:phpmyadmin:2.2_rc2
* cpe:/a:phpmyadmin:phpmyadmin:2.5.0
* cpe:/a:phpmyadmin:phpmyadmin:2.5.1
* cpe:/a:phpmyadmin:phpmyadmin:2.5.2
* cpe:/a:phpmyadmin:phpmyadmin:2.5.2_pl1
* cpe:/a:phpmyadmin:phpmyadmin:2.5.3
* cpe:/a:phpmyadmin:phpmyadmin:2.6.0_pl1
* cpe:/a:phpmyadmin:phpmyadmin:2.5.7_pl1
* cpe:/a:phpmyadmin:phpmyadmin:2.5.7
* cpe:/a:phpmyadmin:phpmyadmin:2.5.6_rc2
* cpe:/a:phpmyadmin:phpmyadmin:2.5.6_rc1
* cpe:/a:phpmyadmin:phpmyadmin:2.5.5_rc2
* cpe:/a:phpmyadmin:phpmyadmin:2.5.5_rc1
* cpe:/a:phpmyadmin:phpmyadmin:2.5.5_pl1
* cpe:/a:phpmyadmin:phpmyadmin:2.5.5
* cpe:/a:phpmyadmin:phpmyadmin:2.5.4
* cpe:/a:phpmyadmin:phpmyadmin:2.6.1_rc1
* cpe:/a:phpmyadmin:phpmyadmin:2.6.1_pl3
* cpe:/a:phpmyadmin:phpmyadmin:2.6.1_pl1
* cpe:/a:phpmyadmin:phpmyadmin:2.6.1
* cpe:/a:phpmyadmin:phpmyadmin:2.6.0_pl3
* cpe:/a:phpmyadmin:phpmyadmin:2.6.0_pl2
* cpe:/a:phpmyadmin:phpmyadmin:2.6.2_pl1
* cpe:/a:phpmyadmin:phpmyadmin:2.6.2_rc1
* cpe:/a:phpmyadmin:phpmyadmin:2.6.2
* cpe:/a:phpmyadmin:phpmyadmin:2.6.2_dev
* cpe:/a:phpmyadmin:phpmyadmin:2.7.0
* cpe:/a:phpmyadmin:phpmyadmin:2.7
* cpe:/a:phpmyadmin:phpmyadmin:2.6.4_pl4
* cpe:/a:phpmyadmin:phpmyadmin:2.6.4_rc1
* cpe:/a:phpmyadmin:phpmyadmin:2.6.4_pl2
* cpe:/a:phpmyadmin:phpmyadmin:2.6.4_pl3
* cpe:/a:phpmyadmin:phpmyadmin:2.6.4
* cpe:/a:phpmyadmin:phpmyadmin:2.6.4_pl1
* cpe:/a:phpmyadmin:phpmyadmin:2.6.3
* cpe:/a:phpmyadmin:phpmyadmin:2.6.3_pl1
* cpe:/a:phpmyadmin:phpmyadmin:2.7.0_beta1
* cpe:/a:phpmyadmin:phpmyadmin:2.7_pl1
* cpe:/a:phpmyadmin:phpmyadmin:2.8.0.2
* cpe:/a:phpmyadmin:phpmyadmin:2.8.0.1
* cpe:/a:phpmyadmin:phpmyadmin:2.8.1
* cpe:/a:phpmyadmin:phpmyadmin:2.8.0.3
* cpe:/a:phpmyadmin:phpmyadmin:2.7.0_pl2
* cpe:/a:phpmyadmin:phpmyadmin:2.7.0_pl1
* cpe:/a:phpmyadmin:phpmyadmin:2.8.0
* cpe:/a:phpmyadmin:phpmyadmin:2.7.0_rc1
* cpe:/a:phpmyadmin:phpmyadmin:2.9
* cpe:/a:phpmyadmin:phpmyadmin:2.9.0_beta1
* cpe:/a:phpmyadmin:phpmyadmin:2.9.0
* cpe:/a:phpmyadmin:phpmyadmin:2.8.2
* cpe:/a:phpmyadmin:phpmyadmin:2.8.1_dev
* cpe:/a:phpmyadmin:phpmyadmin:2.8.4
* cpe:/a:phpmyadmin:phpmyadmin:2.8.3
* cpe:/a:phpmyadmin:phpmyadmin:2.9.0.3
* cpe:/a:phpmyadmin:phpmyadmin:2.9.0.1
* cpe:/a:phpmyadmin:phpmyadmin:2.9.0.2
* cpe:/a:phpmyadmin:phpmyadmin:2.9_rc1
* cpe:/a:phpmyadmin:phpmyadmin:2.9.1.1
* cpe:/a:phpmyadmin:phpmyadmin:2.9.2
* cpe:/a:phpmyadmin:phpmyadmin:2.9.1
* cpe:/a:phpmyadmin:phpmyadmin:2.9.1_rc1
* cpe:/a:phpmyadmin:phpmyadmin:2.9.1_rc2
* cpe:/a:phpmyadmin:phpmyadmin:2.9.0_dev
* cpe:/a:phpmyadmin:phpmyadmin:2.9.0_rc1
Collapse OROR
cpe:/a:microsoft:internet_explorer
* Denotes Vulnerable Software
Changes related to vulnerability configurations

Technical Details

Vulnerability Type (View All)
  • Cross-Site Scripting (XSS) (CWE-79)